当前位置: 主页 > 业内 >

Yeti 0.2.3 发布,JavaScript 测试运行器

时间:2013-05-28 09:14来源:www.oschina.net 作者:admin 点击:
Yeti 0.2.23 发布了,修复了一些小 bug,主要是 IE9 下的问题,包括: Changes Ignoring server option no longer appears when glob config is used with-s. Fix GH-35 . Fix thrown SyntaxError on IE for every test when Yeti is u
欢迎大家分享自己的文档,请点击查阅:分享方法,Linux系统运维
如果你喜欢这文章,可以点击文章结尾处百度分享,分享到你的各种社区收藏,或推荐给朋友……


Yeti 0.2.23 发布了,修复了一些小 bug,主要是 IE9 下的问题,包括:

Changes

  • “Ignoring –server option” no longer appears when glob config is used with -s. Fix GH-35.
  • Fix thrown SyntaxError on IE for every test when Yeti is used on port 80 or 443. Fix GH-46.
  • Avoid using devDependencies during postinstall. Workaround for npm bugs. Fix GH-42.
  • Update onyx dependency.

可通过运行 npm install -g yeti 来升级。

Yeti 是一个浏览器上的 JavaScript 测试运行器,基于 Node.js。你可以使用 Yeti 来测试 YUI 每个部件。

安装和使用:

01 $ npm install -g yeti
02 $ yeti test/*.html
03 Connected to http://localhost:9000
04   Agent connected: Chrome (22.0.1221.0) / Mac OS
05   Agent connected: Safari (6.0) / Mac OS
06 ✔ Testing started on Chrome (22.0.1221.0) / Mac OS, Safari (6.0) / Mac OS
07 ✔ Agent completed: Chrome (22.0.1221.0) / Mac OS
08 ✔ Agent completed: Safari (6.0) / Mac OS
09 504 tests passed! (11.5 seconds)
10 $

转载请注明linux系统运维
http://www.linuxyw.com/linux/yenei/2013/0528/480.html

------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
验证码: 点击我更换图片