当前位置: 主页 > 业内 >

HAproxy 1.5.0 dev19/1.4.24 新版本修复BUG

时间:2013-06-18 10:30来源:www.oschina.net 作者:admin 点击:
HAproxy 今天发布了两个新版本,分别是稳定版 1.4.24 和开发版 1.5.0 dev19.并提供下载,请及时更新 其中 1.5.0 dev19 修复了两个潜在的可能通过远程触发导致程序崩溃的问题 (CVE-2013-2175) ,同
欢迎大家分享自己的文档,请点击查阅:分享方法,Linux系统运维
如果你喜欢这文章,可以点击文章结尾处百度分享,分享到你的各种社区收藏,或推荐给朋友……


HAproxy 今天发布了两个新版本,分别是稳定版 1.4.24 和开发版 1.5.0 dev19.并提供下载,请及时更新

其中 1.5.0 dev19 修复了两个潜在的可能通过远程触发导致程序崩溃的问题 (CVE-2013-2175) ,同时合并了最近时间做的改动,包括 http-response, 动态设置优先级、DSCP 头、Netfilter 掩码和日志级别,以及在 BSD 上的透明代理等等;简化了文档,所有的 1.5 用户请立即升级。

而 1.4.24 版本主要是 bug 修复:修复了配置实用 hdr_ip(name,-1) 或者 usesrc hdr_ip(name) 导致程序崩溃问题 ( CVE-2013-2175) ,建议所有 1.4 用户尽快升级。

HAproxy 1.5.0 dev19/1.4.24下载地址:http://haproxy.1wt.eu/download/1.4/

 

HAProxy提供高可用性负载均衡以及基于TCP和HTTP应用的代理,支持虚拟主机,它是免费、快速并且可靠的一种解决方案。HAProxy特别适用于那些负载特大的web站点, 这些站点通常又需要会话保持或七层处理。HAProxy运行在当前的硬件上,完全可以支持数以万计的并发连接。并且它的运行模式使得它可以很简单安全的整合进您当前的架构中, 同时可以保护你的web服务器不被暴露到网络上。

下图是HAProxy的架构:

下图是HAProxy的监控页面截图:

 

HAProxy实现了一种事件驱动单一进程模型,此模型支持非常大的并发连接数。多进程或多线程模型受内存限制 、系统调度器限制以及无处不在的锁限制,很少能处理数千并发连接。事件驱动模型因为在有更好的资源和时间管理的用户端(User-Space) 实现所有这些任务,所以没有这些问题。此模型的弊端是,在多核系统上,这些程序通常扩展性较差。这就是为什么他们必须进行优化以 使每个CPU时间片(Cycle)做更多的工作。

转载请注明linux系统运维
http://www.linuxyw.com/linux/yenei/2013/0618/577.html

------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
验证码: 点击我更换图片